1. 05 Feb, 2021 1 commit
  2. 06 Feb, 2020 1 commit
  3. 05 Feb, 2020 1 commit
  4. 22 Jan, 2020 1 commit
  5. 08 Dec, 2019 1 commit
  6. 07 Dec, 2019 1 commit
    • Bernhard Geier's avatar
      Allgemein: Ubuntu 18.04 hat standardmäßig kein ifupdown sondern benutzt... · dbfd2a2e
      Bernhard Geier authored
      Allgemein: Ubuntu 18.04 hat standardmäßig kein ifupdown sondern benutzt Netplan. ifupdown muss nachinstalliert werden.
      
      - bird: Debian 8-Unterstützung entfernt, ansible-lint Warnungen behoben
      - common: Debian 8-Unterstützung entfernt, ansible-lint Warnungen behoben, ifupdown installieren
      - gateways_l2tp_slovenija: unbenutzte Handler entfernt, Debian 8-Unterstützung entfernt, ansible-lint Warnungen behoben
      - nrpe: In Ubuntu 16.04 gibt es das Paket dhcp-pools nicht, daher nicht versuchen es zu installieren
      - py_respondd: Abhängigkeiten für Ubuntu 16.04 und 18.04 repariert, ansible-lint Warnungen behoben, service erst nach network.target starten
      - gateways_dhcp: Nicht benötigten isc-dhcp-server6.service (gibt's nur in Ubuntu) deaktivieren
      dbfd2a2e
  7. 06 Dec, 2019 1 commit
  8. 04 Dec, 2019 2 commits
  9. 01 Dec, 2019 2 commits
    • Bernhard Geier's avatar
      - Kommentar "Ansible managed" zu Dateien mit Secret- und Public-Key hinzugefügt · 025ab0a7
      Bernhard Geier authored
      - Nicht mehr versuchen, das fastd-Interface aus den Domänen-Bridges zu entfernen, passiert automatisch.
      - Erlaube Überschreiben des mit fastd.port_base+Domänennummer errechneten fastd-Ports durch Setzen von "domaenen.[<DOMÄNE>].fastd_port_forced=<PORT>"
      - fastd-keys können in "domaenenliste" für jede Domäne angegeben werden:
        - domaenenliste.<DOMÄNE>.fastd_key.secret: "SECRETKEY"
        - domaenenliste.<DOMÄNE>.fastd_key.public: "PUBLICKEY"
      
        Beispiel:
        ---------
        domaenenliste:
          "17":
            dhcp_start: 10.17.80.0
            dhcp_ende: 10.17.95.255
            fastd: true
            fastd_key:
              secret: "5f06e8776dcb8916da72e02b7bc7fde17ebdde570befb9254e7c93eceb75fcb1"
              public: "775c9aa513227e580253df4c7e4cd3c541daeaba8f3119e548530814b0ac2a9a"
      
        fastd wird nur dann für eine Domäne aktiviert, wenn der Schlüssel "fastd" exisitiert und auf "true" gesetzt ist, oder wenn der Schlüssel "fastd_key" exisitiert.
        Ist "fastd" auf "false" gesetzt, wird fastd nicht aktiviert, ganz gleich ob "fastd_key" existiert.
      025ab0a7
    • Bernhard Geier's avatar
      batman_install: · c17e9255
      Bernhard Geier authored
      - Überflüssige Schritte entfernt
      - ansible-lint-Warnungen behoben
      - check_mode repariert
      - Bei Versionswechsel des batman-adv-Kernelmoduls werden die Batman-Interfaces neu gestartet
      c17e9255
  10. 23 Nov, 2019 1 commit
    • Bernhard Geier's avatar
      nrpe: check_batip/check_batip6 · 3b46b94a
      Bernhard Geier authored
      - Umlaute korrigiert
      - Feste IP-Adressen ersetzt durch die IP-Adressen von max. zwei Mapserver und der ersten max. vier Gateways
      - Status "Fehler" wenn weniger als die Hälfte der IP-Adressen erreichbar sind
      3b46b94a
  11. 22 Nov, 2019 1 commit
  12. 15 Nov, 2019 8 commits
  13. 10 Nov, 2019 1 commit
  14. 08 Nov, 2019 1 commit
  15. 06 Nov, 2019 2 commits
    • wusel42's avatar
      Add support for batman-adv-legacy (2013.4.0, a Gluon-team maintained batman-adv v14). · 41bf9797
      wusel42 authored
      Includes quick'n'dirty workaround with 2013.4.0, as somhehow "dkms remove batman-adv/2013.4.0 -k $(uname -r)" does not work:
      
      root@fastd-ham02 ~ # dkms status batman-adv -k 4.15.0-20-generic | grep -Eo '[[:digit:]]{4}\.[[:digit:]](\.[[:digit:]])?' || true
      2013.4.0
      root@fastd-ham02 ~ # dkms remove batman-adv/2013.4.0 -k 4.15.0-20-generic
      Error! There is no instance of batman-adv 2013.4.0
      for kernel 4.15.0-20-generic (x86_64) located in the DKMS tree.
      root@fastd-ham02 ~ # dkms remove batman-adv/2013.4.0 --all
      
      ------------------------------
      Deleting module version: 2013.4.0
      completely from the DKMS tree.
      ------------------------------
      Done.
      root@fastd-ham02 ~ # dkms status batman-adv -k 4.15.0-20-generic | grep -Eo '[[:digit:]]{4}\.[[:digit:]](\.[[:digit:]])?' || true
      root@fastd-ham02 ~ #
      41bf9797
    • Kai Siering's avatar
      Match 2017.4 as well as 2013.4.0 ... · 942ecddd
      Kai Siering authored
      942ecddd
  16. 03 Nov, 2019 2 commits
  17. 01 Nov, 2019 1 commit
  18. 29 Oct, 2019 1 commit
  19. 28 Oct, 2019 11 commits