diff --git a/alfred-sensors/Makefile b/alfred-sensors/Makefile
new file mode 100644
index 0000000000000000000000000000000000000000..36aa48223330b198666c4500d857b3d3ee9de3c3
--- /dev/null
+++ b/alfred-sensors/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ffnw-sensors
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ffnw-sensors
+  SECTION:=sensors
+  CATEGORY:=Freifunk Nordwest
+  TITLE:=Provides sensor data for alfred
+endef
+
+define Package/ffnw-sensors/description
+	Provides sensor data for alfred
+endef
+
+define Build/Prepare
+	mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/ffnw-sensors/install
+	$(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,ffnw-sensors))
diff --git a/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/hPa b/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/hPa
new file mode 100644
index 0000000000000000000000000000000000000000..0adffdbbc865973accdef54506306512263367cb
--- /dev/null
+++ b/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/hPa
@@ -0,0 +1 @@
+return tonumber(fs.readfile('/tmp/luftdruck'))
diff --git "a/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/\302\260C" "b/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/\302\260C"
new file mode 100644
index 0000000000000000000000000000000000000000..6622eef6c842c29c1fb3b995d2495e5f033c8b17
--- /dev/null
+++ "b/alfred-sensors/files/lib/gluon/announce/nodeinfo.d/sensors/\302\260C"
@@ -0,0 +1 @@
+return tonumber(fs.readfile('/tmp/temperatur'))