diff --git a/hoods/Makefile b/hoods/Makefile
index 5071500d76b5ad3c84114fc37329a17c8413716c..ecdbe1f1f36dc64a6fd375168635d38c9b2f99aa 100644
--- a/hoods/Makefile
+++ b/hoods/Makefile
@@ -4,6 +4,8 @@ PKG_NAME:=ffnw-hoods
 PKG_VERSION:=1
 PKG_RELEASE:=1
 
+PKG_BUILD_DEPENDS := luci-base/host lua-cjson/host
+
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,7 +31,8 @@ define Build/Compile
 endef
 
 define Package/$(PKG_NAME)/install
-	$(CP) ./files/* $(1)/
+	$(INSTALL_DIR) $(1)/lib/ffnw/hoods
+	lua -e 'local cjson = require("cjson"); print(cjson.encode(cjson.decode(assert(io.open("./files/lib/ffnw/hoods/hoods.json"):read("*a")))))' > $(1)/lib/ffnw/hoods/hoods.json
 endef
 
 $(eval $(call BuildPackage,$(PKG_NAME)))