diff --git a/libwlocate/Makefile b/libwlocate/Makefile
index 0ecd77c9491db6986d6f9954ca8006bb14c940f0..262304124b34548547a6596c870625d8bc541e33 100644
--- a/libwlocate/Makefile
+++ b/libwlocate/Makefile
@@ -36,15 +36,10 @@ define Build/Prepare
 	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
-define Build/InstallDev
+define Package/libwlocate/install
 	$(INSTALL_DIR) $(1)/usr/include
 	$(CP) $(PKG_BUILD_DIR)/libwlocate.h $(1)/usr/include/
-	
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_BUILD_DIR)/libwlocate.so $(1)/usr/lib/
-endef
 
-define Package/libwlocate/install
 	$(INSTALL_DIR) $(1)/usr/lib
 	$(CP) $(PKG_BUILD_DIR)/libwlocate.so $(1)/usr/lib/
 endef