From c25b81992b9588cf8e9146047cc9d8d6d2b0da8a Mon Sep 17 00:00:00 2001
From: Jan-Tarek Butt <tarek@ring0.de>
Date: Tue, 31 May 2016 18:44:35 +0200
Subject: [PATCH] remove dofile because it loads files as lua

---
 hoods/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/hoods/Makefile b/hoods/Makefile
index 1642fb5..ecdbe1f 100644
--- a/hoods/Makefile
+++ b/hoods/Makefile
@@ -32,7 +32,7 @@ endef
 
 define Package/$(PKG_NAME)/install
 	$(INSTALL_DIR) $(1)/lib/ffnw/hoods
-	lua -e 'print(require("cjson").encode(assert(dofile("./files/lib/ffnw/hoods/hoods.json"))))' > $(1)/lib/ffnw/hoods/hoods.json
+	lua -e 'local cjson = require("cjson"); print(cjson.encode(cjson.decode(assert(io.open("./files/lib/ffnw/hoods/hoods.json"):read("*a")))))' > $(1)/lib/ffnw/hoods/hoods.json
 endef
 
 $(eval $(call BuildPackage,$(PKG_NAME)))
-- 
GitLab