diff --git a/hoodselector/Makefile b/hoodselector/Makefile
index 1e5b777e72b5fe08ca30d33eb3d8279a65313ece..4279c1b97a242b1bb70fba88f6ddf7deaecf2837 100644
--- a/hoodselector/Makefile
+++ b/hoodselector/Makefile
@@ -30,6 +30,8 @@ define Build/Compile
 endef
 
 define Package/$(PKG_NAME)/install
+	sed -e 's/--.*//' -e '/^$$/d' ./files/usr/sbin/hoodselector > ./files/usr/sbin/hoodselector
+	chmod +x ./files/usr/sbin/hoodselector
 	$(CP) ./files/* $(1)/
 endef