From 05403bb3b415aa06ff14b5ea6a9934f2cc55d6ad Mon Sep 17 00:00:00 2001
From: Jan-Tarek Butt <tarek@ring0.de>
Date: Fri, 26 Aug 2016 23:59:49 +0200
Subject: [PATCH] integrate respondd make params

---
 hoodselector/Makefile | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/hoodselector/Makefile b/hoodselector/Makefile
index 359d929..b13ae59 100644
--- a/hoodselector/Makefile
+++ b/hoodselector/Makefile
@@ -5,16 +5,16 @@ PKG_VERSION:=1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DEPENDS := lua/host luci-base/host respondd
 
-PKG_BUILD_DEPENDS += lua/host luci-base/host
+include $(GLUONDIR)/include/package.mk
 
-include $(INCLUDE_DIR)/package.mk
 
 define Package/ffnw-hoodselector
   SECTION:=networke
   CATEGORY:=Freifunk Nordwest
   TITLE:=Select the hoods depending on the geo coordinate
-  DEPENDS:=+lwtrace +ffnw-hoods +luci-lib-jsonc gluon-mesh-batman-adv-15 +gluon-mesh-vpn-fastd
+  DEPENDS:=+lwtrace +ffnw-hoods +luci-lib-jsonc gluon-mesh-batman-adv-15 +gluon-mesh-vpn-fastd +respondd
 endef
 
 define Package/ffnw-hoodselector/description
@@ -34,18 +34,22 @@ define Build/Prepare
 	$(CP) ./luasrc/* $(PKG_BUILD_DIR)/
 	$(call SrcDiet,$(PKG_BUILD_DIR),$(PKG_BUILD_DIR))
 	chmod +x -R $(PKG_BUILD_DIR)/
+	$(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
 define Build/Configure
 endef
 
 define Build/Compile
+	$(call Build/Compile/Default)
 endef
 
 define Package/ffnw-hoodselector/install
 	$(CP) ./files/* $(1)/
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(CP) $(PKG_BUILD_DIR)/hoodselector $(1)/usr/sbin/hoodselector
+	$(INSTALL_DIR) $(1)/lib/gluon/respondd
+	$(CP) $(PKG_BUILD_DIR)/respondd.so $(1)/lib/gluon/respondd/hoodselector.so
 endef
 
 $(eval $(call BuildPackage,ffnw-hoodselector))
-- 
GitLab